Branch Network
myAlpha
Troubleshooting-Error messages BACK

The message "Internet Explorer Script Error" was displayed while I was trying to log into Alpha Private Web. What does this mean?

This message is displayed in case the browser version you use (e.g. Internet Explorer 4) is not compatible for the use of Alpha Private Web.

To log into Alpha Private Web, the operating system must be Microsoft Windows XP or NT 4.0 or 2000 and the browser should be preferably Internet Explorer 5.5 or later or Netscape Communicator 7.2 or Mozilla Firefox 1.0 or later.

Secure electronic transactions
The security of your transactions is our priority. We ask our Customers to follow the guidelines for the security of electronic transactions provided by Alpha Bank, especially at this time that phishing attacks have significantly increased.

For the proper operation of our website www.alpha.gr, we are required to use cookies. Subject to your consent, we will use additional cookies to improve the browsing experience, of our website, to obtain performance and functionality analytics and provide advertising tailored to your needs. If you agree to the use of all additional cookies, select “ACCEPT”. If you do not wish the additional cookies to be installed, select “DECLINE” or be informed about our Cookie Policy as well as the different types of cookies, and declare or change your preferences (except for technically essential cookies, which cannot be deactivated), by clicking on “Cookie Settings”.